Dependency Convergence

Legend:
error At least one dependency has a differing version of the dependency or has SNAPSHOT dependencies.

Statistics:
Number of dependencies (NOD): 48
Number of unique artifacts (NOA): 50
Number of version-conflicting artifacts (NOC): 2
Number of SNAPSHOT artifacts (NOS): 9
Convergence (NOD/NOA): error 96 %
Ready for release (100 % convergence and no SNAPSHOTS): error Error
You do not have 100 % convergence.
You have SNAPSHOT dependencies.

Dependencies used in this project

com.google.code.findbugs:jsr305

error
1.3.9
    org.openflexo:gina-swing:jar:2.1.1-SNAPSHOT
    \- org.openflexo:gina-api:jar:2.1.1-SNAPSHOT:compile
       \- org.openflexo:connie-core:jar:1.4.1-SNAPSHOT:compile
          \- com.google.guava:guava:jar:23.6-jre:compile
             \- (com.google.code.findbugs:jsr305:jar:1.3.9:compile - omitted for conflict with 2.0.1)

2.0.1
    org.openflexo:gina-swing:jar:2.1.1-SNAPSHOT
    \- org.openflexo:gina-api:jar:2.1.1-SNAPSHOT:compile
       \- org.openflexo:connie-core:jar:1.4.1-SNAPSHOT:compile
          \- org.openflexo:connie-parser:jar:1.4.1-SNAPSHOT:compile
             \- com.google.code.findbugs:jsr305:jar:2.0.1:compile

commons-io:commons-io

error
1.3.1
    org.openflexo:gina-swing:jar:2.1.1-SNAPSHOT
    \- org.openflexo:gina-api:jar:2.1.1-SNAPSHOT:compile
       \- org.openflexo:flexographicutils:jar:2.1.1-SNAPSHOT:compile
          \- org.apache.xmlgraphics:batik-dom:jar:1.9.1:compile
             \- org.apache.xmlgraphics:batik-css:jar:1.9.1:compile
                \- org.apache.xmlgraphics:xmlgraphics-commons:jar:2.2:compile
                   \- (commons-io:commons-io:jar:1.3.1:compile - omitted for conflict with 2.6)

2.6
    org.openflexo:gina-swing:jar:2.1.1-SNAPSHOT
    \- org.openflexo:gina-events:jar:2.1.1-SNAPSHOT:compile
       \- org.openflexo:pamela-core:jar:1.4.1-SNAPSHOT:compile
          \- org.openflexo:flexoutils:jar:1.4.1-SNAPSHOT:compile
             \- commons-io:commons-io:jar:2.6:compile

org.openflexo:connie-core

error
1.4.1-SNAPSHOT
    org.openflexo:gina-swing:jar:2.1.1-SNAPSHOT
    +- org.openflexo:gina-events:jar:2.1.1-SNAPSHOT:compile
    |  \- org.openflexo:pamela-core:jar:1.4.1-SNAPSHOT:compile
    |     \- (org.openflexo:connie-core:jar:1.4.1-SNAPSHOT:compile - omitted for duplicate)
    \- org.openflexo:gina-api:jar:2.1.1-SNAPSHOT:compile
       +- org.openflexo:connie-core:jar:1.4.1-SNAPSHOT:compile
       \- org.openflexo:flexolocalization:jar:2.1.1-SNAPSHOT:compile
          \- (org.openflexo:connie-core:jar:1.4.1-SNAPSHOT:compile - omitted for duplicate)

org.openflexo:connie-parser

error
1.4.1-SNAPSHOT
    org.openflexo:gina-swing:jar:2.1.1-SNAPSHOT
    \- org.openflexo:gina-api:jar:2.1.1-SNAPSHOT:compile
       \- org.openflexo:connie-core:jar:1.4.1-SNAPSHOT:compile
          \- org.openflexo:connie-parser:jar:1.4.1-SNAPSHOT:compile

org.openflexo:flexographicutils

error
2.1.1-SNAPSHOT
    org.openflexo:gina-swing:jar:2.1.1-SNAPSHOT
    \- org.openflexo:gina-api:jar:2.1.1-SNAPSHOT:compile
       \- org.openflexo:flexographicutils:jar:2.1.1-SNAPSHOT:compile

org.openflexo:flexolocalization

error
2.1.1-SNAPSHOT
    org.openflexo:gina-swing:jar:2.1.1-SNAPSHOT
    \- org.openflexo:gina-api:jar:2.1.1-SNAPSHOT:compile
       +- org.openflexo:flexolocalization:jar:2.1.1-SNAPSHOT:compile
       \- org.openflexo:flexographicutils:jar:2.1.1-SNAPSHOT:compile
          \- (org.openflexo:flexolocalization:jar:2.1.1-SNAPSHOT:compile - omitted for duplicate)

org.openflexo:flexoutils

error
1.4.1-SNAPSHOT
    org.openflexo:gina-swing:jar:2.1.1-SNAPSHOT
    +- org.openflexo:gina-events:jar:2.1.1-SNAPSHOT:compile
    |  \- org.openflexo:pamela-core:jar:1.4.1-SNAPSHOT:compile
    |     \- org.openflexo:flexoutils:jar:1.4.1-SNAPSHOT:compile
    \- org.openflexo:gina-api:jar:2.1.1-SNAPSHOT:compile
       +- org.openflexo:connie-core:jar:1.4.1-SNAPSHOT:compile
       |  \- (org.openflexo:flexoutils:jar:1.4.1-SNAPSHOT:compile - omitted for duplicate)
       +- org.openflexo:flexolocalization:jar:2.1.1-SNAPSHOT:compile
       |  \- (org.openflexo:flexoutils:jar:1.4.1-SNAPSHOT:compile - omitted for duplicate)
       \- org.openflexo:flexographicutils:jar:2.1.1-SNAPSHOT:compile
          \- (org.openflexo:flexoutils:jar:1.4.1-SNAPSHOT:compile - omitted for duplicate)

org.openflexo:gina-api

error
2.1.1-SNAPSHOT
    org.openflexo:gina-swing:jar:2.1.1-SNAPSHOT
    +- org.openflexo:gina-api:jar:2.1.1-SNAPSHOT:compile
    \- org.openflexo:gina-core:jar:2.1.1-SNAPSHOT:compile
       +- (org.openflexo:gina-api:jar:2.1.1-SNAPSHOT:compile - omitted for duplicate)
       \- org.openflexo:gina-test:jar:2.1.1-SNAPSHOT:compile
          \- (org.openflexo:gina-api:jar:2.1.1-SNAPSHOT:compile - omitted for duplicate)

org.openflexo:gina-events

error
2.1.1-SNAPSHOT
    org.openflexo:gina-swing:jar:2.1.1-SNAPSHOT
    +- org.openflexo:gina-events:jar:2.1.1-SNAPSHOT:compile
    \- org.openflexo:gina-api:jar:2.1.1-SNAPSHOT:compile
       \- (org.openflexo:gina-events:jar:2.1.1-SNAPSHOT:compile - omitted for duplicate)

org.openflexo:gina-test

error
2.1.1-SNAPSHOT
    org.openflexo:gina-swing:jar:2.1.1-SNAPSHOT
    \- org.openflexo:gina-core:jar:2.1.1-SNAPSHOT:compile
       \- org.openflexo:gina-test:jar:2.1.1-SNAPSHOT:compile

org.openflexo:pamela-core

error
1.4.1-SNAPSHOT
    org.openflexo:gina-swing:jar:2.1.1-SNAPSHOT
    +- org.openflexo:gina-events:jar:2.1.1-SNAPSHOT:compile
    |  \- org.openflexo:pamela-core:jar:1.4.1-SNAPSHOT:compile
    \- org.openflexo:gina-api:jar:2.1.1-SNAPSHOT:compile
       +- (org.openflexo:pamela-core:jar:1.4.1-SNAPSHOT:compile - omitted for duplicate)
       \- org.openflexo:flexolocalization:jar:2.1.1-SNAPSHOT:compile
          \- (org.openflexo:pamela-core:jar:1.4.1-SNAPSHOT:compile - omitted for duplicate)