Reactor Dependency Convergence

Legend:
error At least one dependency has a differing version of the dependency or has SNAPSHOT dependencies.

Statistics:
Number of modules: 8
Number of dependencies (NOD): 74
Number of unique artifacts (NOA): 88
Number of version-conflicting artifacts (NOC): 7
Number of SNAPSHOT artifacts (NOS): 10
Convergence (NOD/NOA): error 84 %
Ready for release (100 % convergence and no SNAPSHOTS): error Error
You do not have 100 % convergence.
You have SNAPSHOT dependencies.

Dependencies used in modules

commons-io:commons-io

error
1.3.1
  1. org.openflexo:gina-api:jar:2.2.1-SNAPSHOT
    \- org.openflexo:flexographicutils:jar:2.2.1-SNAPSHOT:compile
       \- org.apache.xmlgraphics:batik-dom:jar:1.13:compile
          \- org.apache.xmlgraphics:batik-css:jar:1.13:compile
             \- org.apache.xmlgraphics:xmlgraphics-commons:jar:2.4:compile
                \- (commons-io:commons-io:jar:1.3.1:compile - omitted for conflict with 2.6)

  2. org.openflexo:gina-events:jar:2.2.1-SNAPSHOT
    \- org.openflexo:flexographicutils:jar:2.2.1-SNAPSHOT:compile
       \- org.apache.xmlgraphics:batik-dom:jar:1.13:compile
          \- org.apache.xmlgraphics:batik-css:jar:1.13:compile
             \- org.apache.xmlgraphics:xmlgraphics-commons:jar:2.4:compile
                \- (commons-io:commons-io:jar:1.3.1:compile - omitted for conflict with 2.6)

  3. org.openflexo:gina-replay:jar:2.2.1-SNAPSHOT
    \- org.openflexo:flexographicutils:jar:2.2.1-SNAPSHOT:compile
       \- org.apache.xmlgraphics:batik-dom:jar:1.13:compile
          \- org.apache.xmlgraphics:batik-css:jar:1.13:compile
             \- org.apache.xmlgraphics:xmlgraphics-commons:jar:2.4:compile
                \- (commons-io:commons-io:jar:1.3.1:compile - omitted for conflict with 2.6)

2.6
  1. org.openflexo:gina-api:jar:2.2.1-SNAPSHOT
    \- org.openflexo:pamela-core:jar:1.5-SNAPSHOT:compile
       \- org.openflexo:flexo-utils:jar:1.5-SNAPSHOT:compile
          +- org.openflexo:connie-utils:jar:1.5-SNAPSHOT:compile
          |  \- (commons-io:commons-io:jar:2.6:compile - omitted for duplicate)
          \- commons-io:commons-io:jar:2.6:compile

  2. org.openflexo:gina-events:jar:2.2.1-SNAPSHOT
    \- org.openflexo:pamela-core:jar:1.5-SNAPSHOT:compile
       \- org.openflexo:flexo-utils:jar:1.5-SNAPSHOT:compile
          +- org.openflexo:connie-utils:jar:1.5-SNAPSHOT:compile
          |  \- (commons-io:commons-io:jar:2.6:compile - omitted for duplicate)
          \- commons-io:commons-io:jar:2.6:compile

  3. org.openflexo:gina-replay:jar:2.2.1-SNAPSHOT
    \- org.openflexo:pamela-core:jar:1.5-SNAPSHOT:compile
       \- org.openflexo:flexo-utils:jar:1.5-SNAPSHOT:compile
          +- org.openflexo:connie-utils:jar:1.5-SNAPSHOT:compile
          |  \- (commons-io:commons-io:jar:2.6:compile - omitted for duplicate)
          \- commons-io:commons-io:jar:2.6:compile

org.openflexo:connie-core

error
1.5-SNAPSHOT
  1. org.openflexo:flexographicutils:jar:2.2.1-SNAPSHOT
    \- org.openflexo:flexolocalization:jar:2.2.1-SNAPSHOT:compile
       \- org.openflexo:pamela-core:jar:1.5-SNAPSHOT:compile (version managed from 1.6-SNAPSHOT)
          \- (org.openflexo:connie-core:jar:1.5-SNAPSHOT:compile - omitted for conflict with 1.5.1-SNAPSHOT)

  2. org.openflexo:gina-core:jar:2.2.1-SNAPSHOT
    \- org.openflexo:pamela-core:jar:1.5-SNAPSHOT:compile
       \- org.openflexo:connie-core:jar:1.5-SNAPSHOT:compile

  3. org.openflexo:gina-replay:jar:2.2.1-SNAPSHOT
    \- org.openflexo:pamela-core:jar:1.5-SNAPSHOT:compile
       \- org.openflexo:connie-core:jar:1.5-SNAPSHOT:compile

1.5.1-SNAPSHOT
  1. org.openflexo:flexographicutils:jar:2.2.1-SNAPSHOT
    \- org.openflexo:flexolocalization:jar:2.2.1-SNAPSHOT:compile
       \- org.openflexo:connie-core:jar:1.5.1-SNAPSHOT:compile

  2. org.openflexo:gina-core:jar:2.2.1-SNAPSHOT
    \- org.openflexo:gina-api:jar:2.2.1-SNAPSHOT:compile
       \- (org.openflexo:connie-core:jar:1.5.1-SNAPSHOT:compile - omitted for conflict with 1.5-SNAPSHOT)

  3. org.openflexo:gina-replay:jar:2.2.1-SNAPSHOT
    \- org.openflexo:gina-swing:jar:2.2.1-SNAPSHOT:compile
       \- (org.openflexo:connie-core:jar:1.5.1-SNAPSHOT:runtime - omitted for conflict with 1.5-SNAPSHOT)

org.openflexo:connie-utils

error
1.5-SNAPSHOT
  1. org.openflexo:flexographicutils:jar:2.2.1-SNAPSHOT
    \- org.openflexo:flexolocalization:jar:2.2.1-SNAPSHOT:compile
       \- org.openflexo:pamela-core:jar:1.5-SNAPSHOT:compile (version managed from 1.6-SNAPSHOT)
          \- org.openflexo:flexo-utils:jar:1.5.1-SNAPSHOT:compile
             \- (org.openflexo:connie-utils:jar:1.5-SNAPSHOT:compile - omitted for conflict with 1.5.1-SNAPSHOT)

1.5.1-SNAPSHOT
  1. org.openflexo:flexographicutils:jar:2.2.1-SNAPSHOT
    \- org.openflexo:flexolocalization:jar:2.2.1-SNAPSHOT:compile
       \- org.openflexo:connie-core:jar:1.5.1-SNAPSHOT:compile
          \- org.openflexo:connie-utils:jar:1.5.1-SNAPSHOT:compile

org.openflexo:flexo-utils

error
1.5-SNAPSHOT
  1. org.openflexo:gina-api:jar:2.2.1-SNAPSHOT
    \- org.openflexo:pamela-core:jar:1.5-SNAPSHOT:compile
       \- org.openflexo:flexo-utils:jar:1.5-SNAPSHOT:compile

  2. org.openflexo:gina-events:jar:2.2.1-SNAPSHOT
    \- org.openflexo:pamela-core:jar:1.5-SNAPSHOT:compile
       \- org.openflexo:flexo-utils:jar:1.5-SNAPSHOT:compile

  3. org.openflexo:gina-replay:jar:2.2.1-SNAPSHOT
    \- org.openflexo:pamela-core:jar:1.5-SNAPSHOT:compile
       \- org.openflexo:flexo-utils:jar:1.5-SNAPSHOT:compile

1.5.1-SNAPSHOT
  1. org.openflexo:gina-api:jar:2.2.1-SNAPSHOT
    \- org.openflexo:flexographicutils:jar:2.2.1-SNAPSHOT:compile
       \- (org.openflexo:flexo-utils:jar:1.5.1-SNAPSHOT:runtime - omitted for conflict with 1.5-SNAPSHOT)

  2. org.openflexo:gina-events:jar:2.2.1-SNAPSHOT
    \- org.openflexo:flexographicutils:jar:2.2.1-SNAPSHOT:compile
       \- (org.openflexo:flexo-utils:jar:1.5.1-SNAPSHOT:runtime - omitted for conflict with 1.5-SNAPSHOT)

  3. org.openflexo:gina-replay:jar:2.2.1-SNAPSHOT
    \- org.openflexo:flexographicutils:jar:2.2.1-SNAPSHOT:compile
       \- (org.openflexo:flexo-utils:jar:1.5.1-SNAPSHOT:runtime - omitted for conflict with 1.5-SNAPSHOT)

org.openflexo:pamela-core

error
1.5-20200630.155100-147




1.5-SNAPSHOT
  1. org.openflexo:gina-api:jar:2.2.1-SNAPSHOT
    +- org.openflexo:pamela-core:jar:1.5-SNAPSHOT:compile
    +- org.openflexo:gina-events:jar:2.2.1-SNAPSHOT:compile
    |  \- (org.openflexo:pamela-core:jar:1.5-SNAPSHOT:runtime - version managed from 1.6-SNAPSHOT; omitted for conflict with 1.5-20200630.155100-147)
    \- org.openflexo:flexolocalization:jar:2.2.1-SNAPSHOT:compile
       \- (org.openflexo:pamela-core:jar:1.5-SNAPSHOT:compile - version managed from 1.6-SNAPSHOT; omitted for conflict with 1.5-20200630.155100-147)

  2. org.openflexo:gina-core:jar:2.2.1-SNAPSHOT
    +- org.openflexo:pamela-core:jar:1.5-SNAPSHOT:compile
    +- org.openflexo:gina-api:jar:2.2.1-SNAPSHOT:compile
    |  \- (org.openflexo:pamela-core:jar:1.5-SNAPSHOT:runtime - version managed from 1.6-SNAPSHOT; omitted for conflict with 1.5-20200630.155100-147)
    +- org.openflexo:gina-events:jar:2.2.1-SNAPSHOT:compile
    |  \- (org.openflexo:pamela-core:jar:1.5-SNAPSHOT:compile - version managed from 1.6-SNAPSHOT; omitted for conflict with 1.5-20200630.155100-147)
    \- org.openflexo:flexolocalization:jar:2.2.1-SNAPSHOT:compile
       \- (org.openflexo:pamela-core:jar:1.5-SNAPSHOT:compile - version managed from 1.6-SNAPSHOT; omitted for conflict with 1.5-20200630.155100-147)

  3. org.openflexo:gina-events:jar:2.2.1-SNAPSHOT
    +- org.openflexo:pamela-core:jar:1.5-SNAPSHOT:compile
    \- org.openflexo:flexolocalization:jar:2.2.1-SNAPSHOT:compile
       \- (org.openflexo:pamela-core:jar:1.5-SNAPSHOT:compile - omitted for conflict with 1.5-20200630.155100-147)

  4. org.openflexo:gina-replay:jar:2.2.1-SNAPSHOT
    +- org.openflexo:pamela-core:jar:1.5-SNAPSHOT:compile
    +- org.openflexo:gina-swing:jar:2.2.1-SNAPSHOT:compile
    |  +- org.openflexo:gina-api:jar:2.2.1-SNAPSHOT:compile
    |  |  \- (org.openflexo:pamela-core:jar:1.5-SNAPSHOT:compile - omitted for conflict with 1.5-20200630.155100-147)
    |  \- org.openflexo:gina-core:jar:2.2.1-SNAPSHOT:compile
    |     \- (org.openflexo:pamela-core:jar:1.5-SNAPSHOT:compile - omitted for conflict with 1.5-20200630.155100-147)
    +- org.openflexo:gina-events:jar:2.2.1-SNAPSHOT:compile
    |  \- (org.openflexo:pamela-core:jar:1.5-SNAPSHOT:compile - omitted for conflict with 1.5-20200630.155100-147)
    \- org.openflexo:flexolocalization:jar:2.2.1-SNAPSHOT:compile
       \- (org.openflexo:pamela-core:jar:1.5-SNAPSHOT:compile - omitted for conflict with 1.5-20200630.155100-147)

org.openflexo:testutils

error
1.5-20200630.140513-111




1.5-SNAPSHOT
  1. org.openflexo:gina-api:jar:2.2.1-SNAPSHOT
    +- org.openflexo:testutils:jar:1.5-SNAPSHOT:compile
    \- org.openflexo:flexolocalization:jar:2.2.1-SNAPSHOT:compile
       \- (org.openflexo:testutils:jar:1.5-SNAPSHOT:compile - omitted for conflict with 1.5-20200630.140513-111)

  2. org.openflexo:gina-core:jar:2.2.1-SNAPSHOT
    +- org.openflexo:gina-events:jar:2.2.1-SNAPSHOT:compile
    |  \- (org.openflexo:testutils:jar:1.5-SNAPSHOT:compile - omitted for conflict with 1.5-20200630.140513-111)
    +- org.openflexo:testutils:jar:1.5-SNAPSHOT:compile
    \- org.openflexo:flexolocalization:jar:2.2.1-SNAPSHOT:compile
       \- (org.openflexo:testutils:jar:1.5-SNAPSHOT:compile - omitted for conflict with 1.5-20200630.140513-111)

  3. org.openflexo:gina-events:jar:2.2.1-SNAPSHOT
    +- org.openflexo:testutils:jar:1.5-SNAPSHOT:compile
    \- org.openflexo:flexolocalization:jar:2.2.1-SNAPSHOT:compile
       \- (org.openflexo:testutils:jar:1.5-SNAPSHOT:compile - omitted for conflict with 1.5-20200630.140513-111)

  4. org.openflexo:gina-replay:jar:2.2.1-SNAPSHOT
    +- org.openflexo:gina-swing:jar:2.2.1-SNAPSHOT:compile
    |  +- org.openflexo:gina-api:jar:2.2.1-SNAPSHOT:compile
    |  |  \- (org.openflexo:testutils:jar:1.5-SNAPSHOT:compile - omitted for duplicate)
    |  \- org.openflexo:gina-core:jar:2.2.1-SNAPSHOT:compile
    |     \- (org.openflexo:testutils:jar:1.5-SNAPSHOT:compile - omitted for duplicate)
    +- org.openflexo:gina-events:jar:2.2.1-SNAPSHOT:compile
    |  \- (org.openflexo:testutils:jar:1.5-SNAPSHOT:compile - omitted for conflict with 1.5-20200630.140513-111)
    +- org.openflexo:testutils:jar:1.5-SNAPSHOT:compile
    \- org.openflexo:flexolocalization:jar:2.2.1-SNAPSHOT:compile
       \- (org.openflexo:testutils:jar:1.5-SNAPSHOT:compile - omitted for conflict with 1.5-20200630.140513-111)

xml-apis:xml-apis

error
1.3.04
  1. org.openflexo:gina-api:jar:2.2.1-SNAPSHOT
    \- org.openflexo:flexographicutils:jar:2.2.1-SNAPSHOT:compile
       \- org.apache.xmlgraphics:batik-dom:jar:1.13:compile
          \- xalan:xalan:jar:2.7.2:compile
             \- xalan:serializer:jar:2.7.2:compile
                \- (xml-apis:xml-apis:jar:1.3.04:compile - omitted for conflict with 1.4.01)

  2. org.openflexo:gina-events:jar:2.2.1-SNAPSHOT
    \- org.openflexo:flexographicutils:jar:2.2.1-SNAPSHOT:compile
       \- org.apache.xmlgraphics:batik-dom:jar:1.13:compile
          \- xalan:xalan:jar:2.7.2:compile
             \- xalan:serializer:jar:2.7.2:compile
                \- (xml-apis:xml-apis:jar:1.3.04:compile - omitted for conflict with 1.4.01)

  3. org.openflexo:gina-replay:jar:2.2.1-SNAPSHOT
    \- org.openflexo:flexographicutils:jar:2.2.1-SNAPSHOT:compile
       \- org.apache.xmlgraphics:batik-dom:jar:1.13:compile
          \- xalan:xalan:jar:2.7.2:compile
             \- xalan:serializer:jar:2.7.2:compile
                \- (xml-apis:xml-apis:jar:1.3.04:compile - omitted for conflict with 1.4.01)

1.4.01
  1. org.openflexo:gina-api:jar:2.2.1-SNAPSHOT
    \- org.openflexo:flexographicutils:jar:2.2.1-SNAPSHOT:compile
       \- org.apache.xmlgraphics:batik-dom:jar:1.13:compile
          \- xml-apis:xml-apis:jar:1.4.01:compile

  2. org.openflexo:gina-events:jar:2.2.1-SNAPSHOT
    \- org.openflexo:flexographicutils:jar:2.2.1-SNAPSHOT:compile
       \- org.apache.xmlgraphics:batik-dom:jar:1.13:compile
          \- xml-apis:xml-apis:jar:1.4.01:compile

  3. org.openflexo:gina-replay:jar:2.2.1-SNAPSHOT
    \- org.openflexo:flexographicutils:jar:2.2.1-SNAPSHOT:compile
       \- org.apache.xmlgraphics:batik-dom:jar:1.13:compile
          \- xml-apis:xml-apis:jar:1.4.01:compile

org.openflexo:connie-core

error
1.5-SNAPSHOT
  1. org.openflexo:flexolocalization:jar:2.2.1-SNAPSHOT
    \- org.openflexo:pamela-core:jar:1.5-SNAPSHOT:compile
       \- org.openflexo:connie-core:jar:1.5-SNAPSHOT:compile

org.openflexo:connie-core

error
1.5.1-SNAPSHOT
  1. org.openflexo:flexographicutils:jar:2.2.1-SNAPSHOT
    \- org.openflexo:flexolocalization:jar:2.2.1-SNAPSHOT:compile
       \- org.openflexo:connie-core:jar:1.5.1-SNAPSHOT:compile

org.openflexo:connie-parser

error
1.5-SNAPSHOT
  1. org.openflexo:flexolocalization:jar:2.2.1-SNAPSHOT
    \- org.openflexo:pamela-core:jar:1.5-SNAPSHOT:compile
       \- org.openflexo:connie-core:jar:1.5-SNAPSHOT:compile
          \- org.openflexo:connie-parser:jar:1.5-SNAPSHOT:compile

org.openflexo:connie-parser

error
1.5.1-SNAPSHOT
  1. org.openflexo:flexographicutils:jar:2.2.1-SNAPSHOT
    \- org.openflexo:flexolocalization:jar:2.2.1-SNAPSHOT:compile
       \- org.openflexo:connie-core:jar:1.5.1-SNAPSHOT:compile
          \- org.openflexo:connie-parser:jar:1.5.1-SNAPSHOT:runtime

org.openflexo:connie-utils

error
1.5-SNAPSHOT
  1. org.openflexo:flexolocalization:jar:2.2.1-SNAPSHOT
    \- org.openflexo:pamela-core:jar:1.5-SNAPSHOT:compile
       +- org.openflexo:flexo-utils:jar:1.5-SNAPSHOT:compile
       |  \- org.openflexo:connie-utils:jar:1.5-SNAPSHOT:compile
       \- org.openflexo:connie-core:jar:1.5-SNAPSHOT:compile
          \- (org.openflexo:connie-utils:jar:1.5-SNAPSHOT:compile - omitted for duplicate)

org.openflexo:connie-utils

error
1.5.1-SNAPSHOT
  1. org.openflexo:flexographicutils:jar:2.2.1-SNAPSHOT
    \- org.openflexo:flexolocalization:jar:2.2.1-SNAPSHOT:compile
       \- org.openflexo:connie-core:jar:1.5.1-SNAPSHOT:compile
          \- org.openflexo:connie-utils:jar:1.5.1-SNAPSHOT:compile

org.openflexo:flexo-utils

error
1.5-SNAPSHOT
  1. org.openflexo:flexolocalization:jar:2.2.1-SNAPSHOT
    \- org.openflexo:pamela-core:jar:1.5-SNAPSHOT:compile
       \- org.openflexo:flexo-utils:jar:1.5-SNAPSHOT:compile

org.openflexo:flexo-utils

error
1.5.1-SNAPSHOT
  1. org.openflexo:flexographicutils:jar:2.2.1-SNAPSHOT
    \- org.openflexo:flexolocalization:jar:2.2.1-SNAPSHOT:compile
       +- org.openflexo:pamela-core:jar:1.5-SNAPSHOT:compile (version managed from 1.6-SNAPSHOT)
       |  \- org.openflexo:flexo-utils:jar:1.5.1-SNAPSHOT:compile
       \- (org.openflexo:flexo-utils:jar:1.5.1-SNAPSHOT:compile - scope updated from runtime; omitted for duplicate)

org.openflexo:pamela-core

error
1.5-SNAPSHOT
  1. org.openflexo:flexographicutils:jar:2.2.1-SNAPSHOT
    \- org.openflexo:flexolocalization:jar:2.2.1-SNAPSHOT:compile
       \- org.openflexo:pamela-core:jar:1.5-SNAPSHOT:compile (version managed from 1.6-SNAPSHOT)

org.openflexo:testutils

error
1.5-SNAPSHOT
  1. org.openflexo:gina-events:jar:2.2.1-SNAPSHOT
    +- org.openflexo:testutils:jar:1.5-SNAPSHOT:compile
    \- org.openflexo:flexolocalization:jar:2.2.1-SNAPSHOT:compile
       \- (org.openflexo:testutils:jar:1.5-SNAPSHOT:compile - omitted for conflict with 1.5-20200630.140513-111)